[repositories] devel: [groups] [packages] [maintainers] [changelog]

 glibc: The GNU libc libraries (source)

Name:glibc
Release:2.29-1mamba
Group:System/Libraries
Maintainer:silvan
Description:The glibc package contains standard libraries which are used by multiple programs on the system.
In order to save disk space and memory, as well as to make upgrading easier, common system code is kept in one place and shared between programs.
This particular package contains the most important sets of shared libraries: the standard C library and the standard math library. Without these two libraries, a Linux system will not function.
The glibc package also contains national language (locale) support.
License:LGPL
Size:15.83 MB
Download:glibc-2.29-1mamba.src.rpm
URL:http://www.gnu.org/software/libc/
Specfile:glibc.spec
Sources:glibc-2.29.tar.xz nscd-logrotate nscd-conf nscd-initscript
Patches:glibc-2.4-manual-syntax-fix.patch glibc-2.6.1-strlcpy_strlcat-1.patch glibc-2.7-memcpy_chk_S.patch glibc-2.9-arm_local_args6.patch glibc-2.7-lowlevellock.patch glibc-2.16.0-localedata_openmamba.patch glibc-2.7-only-lookup-ipv6-if-it-makes-sense.patch glibc-2.7-gcc-4.3.patch glibc-2.7-x86-fnstsw.patch glibc-2.10.1-binutils-2.20.patch glibc-2.11.2-gcc-4.5.0.patch glibc-2.13-fix_prelink_ld_so.patch glibc-2.14.1-fix-segfault-at-dl-lookup.patch glibc-2.14-fix-resolver-crash-typo.patch glibc-2.14-rpc_nis_headers_restore.patch glibc-ports-2.15-arm-libmemusage-libc_nonshared.patch glibc-2.16.0-tetex-3.0.patch glibc-2.21-prevent-ehaustion-of-tls-slots.patch glibc-2.25-resolv-no-compat.patch 
Build time:Thu Feb 28 2019
Built RPMS:cross-arm-openmamba-linux-gnueabi-glibc(i586) cross-arm-openmamba-linux-gnueabihf-glibc(i586) cross-x86_64-openmamba-linux-gnu-glibc(i586) glibc(i586) glibc-apidocs(i586) glibc-debug(i586) glibc-devel(i586) glibc-i18ndata(i586) glibc-profile(i586) glibc-utils(i586) ldconfig(i586) locales(i586) nscd(i586) timezone(i586) cross-arm-openmamba-linux-gnueabihf-glibc(arm) glibc(arm) glibc-apidocs(arm) glibc-debug(arm) glibc-devel(arm) glibc-i18ndata(arm) glibc-profile(arm) glibc-utils(arm) ldconfig(arm) locales(arm) nscd(arm) timezone(arm) cross-arm-openmamba-linux-gnueabi-glibc(x86_64) cross-arm-openmamba-linux-gnueabihf-glibc(x86_64) glibc(x86_64) glibc-apidocs(x86_64) glibc-debug(x86_64) glibc-devel(x86_64) glibc-i18ndata(x86_64) glibc-multilib(x86_64) glibc-multilib-apidocs(x86_64) glibc-multilib-devel(x86_64) glibc-multilib-i18ndata(x86_64) glibc-multilib-profile(x86_64) glibc-multilib-utils(x86_64) glibc-profile(x86_64) glibc-utils(x86_64) ldconfig(x86_64) ldconfig-multilib(x86_64) locales(x86_64) locales-multilib(x86_64) nscd(x86_64) nscd-multilib(x86_64) timezone(x86_64) timezone-multilib(x86_64)
Build requirements:binutils[>=2.13] bison coreutils[>=5.2.1] gawk gettext-devel[>=0.14.0] kernelsanitisedheaders(kernel-mamba-64GB-headers-sanitised|kernel-mamba-headers-sanitised|kernel-mamba-longterm-4GB-headers-sanitised|kernel-mamba-longterm-headers-sanitised) libcap-devel libgd-devel libidn-devel libpng-devel libselinux-devel libz-devel perl[>=5.8.0] texinfo[>=4.8]
Changelog:Thu Feb 28 2019 - autodist (2.29-1mamba)
- automatic version update by autodist
Sun Sep 23 2018 - silvan (2.28-3mamba)
- glibc: require locales package
Fri Sep 21 2018 - silvan (2.28-2mamba)
- multiarch: move tools from glibc to glibc-utils and require it; ix86: obsolete glibc-multilib
Wed Aug 01 2018 - autodist (2.28-1mamba)
- automatic version update by autodist

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.