[repositories] devel: [groups] [packages] [maintainers] [changelog]

 libdevil: A full featured cross-platform image library

Name:libdevil
Release:1.8.0-1mamba
Architecture:i586
Group:System/Libraries
Description:Developer's Image Library (DevIL) is a programmer's library to develop applications with very powerful image loading capabilities, yet is easy for a developer to learn and use. Ultimate control of images is left to the developer, so unnecessary conversions, etc. are not performed. DevIL utilizes a simple, yet powerful, syntax. DevIL can load, save, convert, manipulate, filter and display a wide variety of image formats.
Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic, .png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif .hdr files.
Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm, .pcx, .hdr, .pgm,.png, .ppm, .raw, .sgi, .tga and .tif.
DevIL currently supports the following APIs for display: OpenGL, Windows GDI, SDL, DirectX and Allegro. Compilers that can compile DevIL or use it include Djgpp, MSVC++, Linux gcc, Delphi, Visual Basic, Power Basic and Dev-C++.
Size:2.83 MB
Download:libdevil-1.8.0-1mamba.i586.rpm
Source RPM:libdevil
Provides:libIL.so.1 libILU.so.1 libILUT.so.1 libdevil[=1.8.0-1mamba] libdevil(x86-32)[=1.8.0-1mamba]
Requires:/bin/sh(bash|dash) /bin/sh(bash|dash) /sbin/install-info libIL.so.1 libILU.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.4) libc.so.6(GLIBC_2.7) libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libjasper.so.4 libjpeg.so.8 libjpeg.so.8(LIBJPEG_8.0) liblcms2.so.2 libm.so.6 libm.so.6(GLIBC_2.0) libm.so.6(GLIBC_2.1) libm.so.6(GLIBC_2.29) libpng16.so.16 libpng16.so.16(PNG16_0) libstdc++.so.6(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.21)(gcc6-c++|libstdc++6) libtiff.so.5 libz.so.1 rtld(GNU_HASH)
RPM requirements:/bin/sh(bash|dash) texinfo glibc libgcc libjasper libjpeg-turbo liblcms2 glibc libpng libstdc++.so.6(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.21)(gcc6-c++|libstdc++6) libtiff libz ldconfig
Required by:libdevil-devel(i586) libgraphviz(i586) spring(i586)
Build required by:
Filenames:/usr/lib/.build-id /usr/lib/.build-id/62 /usr/lib/.build-id/62/9dbde57f8d2132a28ca7de19d61f9efae72669 /usr/lib/.build-id/8c /usr/lib/.build-id/8c/422f86e0ed42c5ec94600ac8b3851c0aa9462b /usr/lib/.build-id/93 /usr/lib/.build-id/93/3a33293f70901b2609916eef79a997667ec1ba /usr/lib/libIL.so.1 /usr/lib/libILU.so.1 /usr/lib/libILUT.so.1 /usr/share/doc/libdevil-1.8.0 /usr/share/doc/libdevil-1.8.0/LICENSE

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.