[repositories] devel: [groups] [packages] [maintainers] [changelog]

 libpcre: PCRE is a Perl-compatible regular expression library

Name:libpcre
Release:8.43-1mamba
Architecture:i586
Group:System/Libraries
Description:PCRE has its own native API, but a set of "wrapper" functions that are based on the POSIX API are also supplied in the library libpcreposix.
Note that this just provides a POSIX calling interface to PCRE: the regular expressions themselves still follow Perl syntax and semantics.
The header file for the POSIX-style functions is called pcreposix.h.
The official POSIX name is regex.h, but I didn't want to risk possible problems with existing files of that name by distributing it that way.
To use it with an existing program that uses the POSIX API, it will have to be renamed or pointed at by a link.
Size:997.92 KB
Download:libpcre-8.43-1mamba.i586.rpm
Source RPM:libpcre
Provides:libpcre.so.1 libpcre.so.3 libpcre16.so.0 libpcre3 libpcre32.so.0 libpcrecpp.so.0 libpcreposix.so.0 libpcre[=8.43-1mamba]
Requires:/sbin/ldconfig /sbin/ldconfig libbz2.so.1.0 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.3) libgcc_s.so.1(libgcc|libgcc6) libgcc_s.so.1(GCC_3.0)(libgcc|libgcc6) libm.so.6 libncurses.so.6 libpcre.so.1 libpcre16.so.0 libpcre32.so.0 libpcreposix.so.0 libreadline.so.7 libstdc++.so.6(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3)(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3.8)(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3.9)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.20)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.21)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.9)(gcc6-c++|libstdc++6) libz.so.1
RPM requirements:ldconfig libbzip2 glibc libgcc_s.so.1(libgcc|libgcc6) libgcc_s.so.1(GCC_3.0)(libgcc|libgcc6) glibc libncurses libreadline7 libstdc++.so.6(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3)(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3.8)(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3.9)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.20)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.21)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.9)(gcc6-c++|libstdc++6) libz
Required by:4store-tools(i586) abiword(i586) aircrack-ng(i586) anjuta(i586) apache(i586) audacity(i586) avahi(i586) avahi-compat-howl(i586) avahi-compat-libdns_sd(i586) avrdude(i586) brasero(i586) ccnet-server(i586) ccze(i586) cheese(i586) cinnamon(i586) cjs(i586) claws-mail(i586) clutter-gst(i586) clutter-gtk(i586) cnijfilter4-mg2500series(i586) codeblocks(i586) cyrus-imapd(i586) dpkg(i586) dvdauthor(i586) empathy(i586) enchant1(i586) enchant1-aspell(i586) enchant1-voikko(i586) evince(i586) falcon(i586) farstream(i586) flatpak(i586) florence(i586) fontconfig(i586) fontforge(i586) freefilesync(i586) freeradius-server(i586) fwts(i586) gambas2-gb-pcre(i586) gambas2-gb-qt-kde-html(i586) gambas3-gb-cairo(i586) gambas3-gb-dbus(i586) gambas3-gb-desktop(i586) gambas3-gb-gtk(i586) gambas3-gb-gtk3(i586) gambas3-gb-image(i586) gambas3-gb-media(i586) gambas3-gb-mime(i586) gambas3-gb-pcre(i586) ganglia(i586) gda(i586) gda4(i586) gdm(i586) geany(i586) gedit(i586) geoclue(i586) gerbv(i586) gjs(i586) gnome-keyring(i586) gnome-keyring-devel(i586) gnome-online-accounts(i586) gnome-system-log(i586) gnome-terminal(i586) gnome-themes-standard(i586) gnome-utils(i586) gnucash(i586) gource(i586) GraphicsMagick(i586) graphviz(i586) grep(i586) gsmartcontrol(i586) gst-plugins-bad(i586) gst-plugins-bad010(i586) gstreamer-tools(i586) gsynaptics(i586) gtk-vnc(i586) gutenprint(i586) gwenhywfar(i586) harfbuzz(i586) hexchat(i586) hfst-ospell(i586) hplip(i586) ImageMagick(i586) ImageMagick69(i586) intel-gpu-tools(i586) iproute(i586) irssi(i586) jamin(i586) kalamaris(i586) kannel(i586) kbarcode(i586) kdelibs(i586) kdelibs3(i586) kino(i586) kmobiletools(i586) kommander(i586) krpmbuilder(i586) libaccounts-glib(i586) libaccounts-glib-devel(i586) libaccounts-glib-tools(i586) libamtk(i586) libappindicator(i586) libappindicator3(i586) libass(i586) libavahi(i586) libavahi-glib(i586) libavahi-gtk3(i586) libavahi-qt3(i586) libblockdev(i586) libblockdev-tools(i586) libcacard(i586) libcairo-tools(i586) libcanberra(i586) libcanberra-gtk2(i586) libcanberra-gtk3(i586) libcaribou(i586) libcaribou-gtk2(i586) libccnet(i586) libcjs(i586) libclutter(i586) libcodeblocks(i586) libcogl(i586) libcroco(i586) libdbus-glib(i586) libdbus-glib-tools(i586) libdc1394(i586) libempathy(i586) libenchant1(i586) libflatpak(i586) libfm(i586) libfontconfig(i586) libfontforge(i586) libfreeradius(i586) libfreetype(i586) libftgl(i586) libfwts(i586) libgames-support(i586) libganglia(i586) libgarcon(i586) libgcj4(i586) libgcr(i586) libgd(i586) libgd-utils(i586) libgda(i586) libgda-mysql(i586) libgda-postgresql(i586) libgdal(i586) libgdata(i586) libgdiplus(i586) libgdk-pixbuf(i586) libgdk-pixbuf-devel(i586) libgdl(i586) libgeany(i586) libgegl(i586) libgegl02(i586) libgjs(i586) libgksu(i586) libglib(i586) libgmime(i586) libgnome-autoar(i586) libgnome-games-support(i586) libgnome-vfs(i586) libgnomekbd(i586) libgoffice08(i586) libgoocanvas(i586) libgphoto2(i586) libGraphicsMagick(i586) libgraphviz(i586) libgraphviz-tcl(i586) libgspell(i586) libgspell-devel(i586) libgst-plugins-base(i586) libgstreamer(i586) libgtk(i586) libgtk-devel(i586) libgtk2(i586) libgtk2-devel(i586) libgtksourceview(i586) libgtkspell3(i586) libgtop(i586) libgtop10(i586) libguestfs(i586) libgupnp-igd(i586) libgvfs(i586) libharfbuzz(i586) libhfstospell(i586) libhidapi(i586) libimlib2(i586) libimlib2-devel(i586) libimlib2-filters(i586) libimlib2-loaders(i586) libkjs(i586) liblangtag(i586) libMagick(i586) libMagick69(i586) libmbim(i586) libmbim-tools(i586) libmuffin(i586) libmypaint(i586) libmysqlclient(i586) libnautilus-extension-sendto(i586) libnice(i586) libnm(i586) libnm-gtk(i586) libopensc(i586) libosinfo(i586) libosinfo-tools(i586) libostree(i586) libpcre-devel(i586) libpcre0-devel(i586) libphodav(i586) libpstoedit(i586) libpulseaudio-glib(i586) libqalculate5(i586) libqalculate7(i586) libqmi(i586) libqmi-tools(i586) librasqal(i586) librest(i586) librsvg(i586) libsane-backends(i586) libscim(i586) libSDL2_ttf(i586) libseafile(i586) libsearpc(i586) libsecret(i586) libsecret-tools(i586) libselinux(i586) libselinux-tools(i586) libsignon-glib(i586) libspeechd(i586) libspice(i586) libspice-gtk(i586) libsyslog-ng(i586) libtotem-pl-parser(i586) libtracker(i586) libuhttpmock(i586) libumockdev(i586) libunity(i586) libunity-tools(i586) libvirt(i586) libvirt-client(i586) libvirt-glib(i586) libvlc(i586) libvolume_key(i586) libvte(i586) libwacom(i586) libwebkit-gtk3(i586) libwxsvg(i586) libxfce4ui(i586) libxfconf(i586) libXft(i586) libyelp(i586) libzeitgeist2(i586) lighttpd(i586) linphone(i586) liquidsoap(i586) maildrop(i586) mariadb(i586) mariadb-client(i586) mc(i586) ModemManager(i586) muffin(i586) nautilus-actions(i586) network-manager-applet(i586) NetworkManager-openconnect(i586) NetworkManager-openvpn(i586) NetworkManager-pptp(i586) NetworkManager-vpnc(i586) nginx(i586) njb-tools(i586) nmap(i586) ocaml-pcre(i586) octave(i586) openocd(i586) opensc(i586) ostree(i586) PackageKit(i586) PackageKit-gtk(i586) PackageKit-gtk2(i586) phodav(i586) php(i586) pkg-config(i586) plymouth(i586) plymouth-x11(i586) postfix(i586) postgis(i586) pstoedit(i586) pulseaudio-module-gsettings(i586) pulseaudio-module-zeroconf(i586) pygobject2(i586) python-appindicator(i586) qalculate5(i586) qalculate7(i586) R(i586) readpst(i586) rhythmbox(i586) rhythmbox-devel(i586) rrdtool(i586) sane(i586) sarg(i586) scilab(i586) seafile(i586) seafile-server(i586) snort(i586) sord(i586) speech-dispatcher(i586) spice-gtk(i586) subversion(i586) swig(i586) syslog-ng(i586) telepathy-farstream(i586) telepathy-gabble(i586) telepathy-mission-control(i586) texlive(i586) texlive-xdvi(i586) Thunar(i586) tracker(i586) udisks2(i586) umockdev(i586) volume_key(i586) wget(i586) xarchiver(i586) xfce4-panel(i586) xorg-server(i586) xorg-server-dmx(i586) yelp(i586) zeitgeist(i586)
Build required by:
Filenames:/usr/bin/pcregrep /usr/bin/pcretest /usr/lib/libpcre.so.1 /usr/lib/libpcre.so.1.2.11 /usr/lib/libpcre.so.3 /usr/lib/libpcre16.so.0 /usr/lib/libpcre16.so.0.2.11 /usr/lib/libpcre32.so.0 /usr/lib/libpcre32.so.0.0.11 /usr/lib/libpcrecpp.so.0 /usr/lib/libpcrecpp.so.0.0.1 /usr/lib/libpcreposix.so.0 /usr/lib/libpcreposix.so.0.0.6 /usr/lib/libpcreposix.so.3 /usr/share/doc/libpcre-8.43 /usr/share/doc/libpcre-8.43/AUTHORS /usr/share/doc/libpcre-8.43/LICENCE /usr/share/man/man1/pcre-config.1.gz /usr/share/man/man1/pcregrep.1.gz /usr/share/man/man1/pcretest.1.gz

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.