[repositories] devel: [groups] [packages] [maintainers] [changelog]

 libpoppler: PDF rendering library (source)

Name:libpoppler
Release:1:0.84.0-2mamba
Group:System/Libraries
Maintainer:aleph0
Description:Poppler is a fork of the xpdf PDF viewer developed by Derek Noonburg of Glyph and Cog, LLC.
Poppler provides PDF rendering functionality as a shared library, to centralize the maintenence effort.
By design, xpdf depends on very few libraries. This is a strong feature and reasonable design goal. However, with poppler we would like to replace parts of xpdf that are now available as standard components of modern Unix desktop environments.
License:GPL
Size:1.51 MB
Download:libpoppler-0.84.0-2mamba.src.rpm
URL:http://poppler.freedesktop.org/
Specfile:libpoppler.spec
Sources:poppler-0.84.0.tar.xz
Build time:Sat Jan 11 2020
Built RPMS:libpoppler(i586) libpoppler-apidocs(i586) libpoppler-cpp(i586) libpoppler-cpp-devel(i586) libpoppler-debug(i586) libpoppler-devel(i586) libpoppler-glib(i586) libpoppler-glib-devel(i586) libpoppler-qt5(i586) libpoppler-qt5-devel(i586) libpoppler-tools(i586) libpoppler(arm) libpoppler-apidocs(arm) libpoppler-cpp(arm) libpoppler-cpp-devel(arm) libpoppler-debug(arm) libpoppler-devel(arm) libpoppler-glib(arm) libpoppler-glib-devel(arm) libpoppler-qt5(arm) libpoppler-qt5-devel(arm) libpoppler-tools(arm) libpoppler(x86_64) libpoppler-apidocs(x86_64) libpoppler-cpp(x86_64) libpoppler-cpp-devel(x86_64) libpoppler-debug(x86_64) libpoppler-devel(x86_64) libpoppler-glib(x86_64) libpoppler-glib-devel(x86_64) libpoppler-qt5(x86_64) libpoppler-qt5-devel(x86_64) libpoppler-tools(x86_64)
Build requirements:glibc-devel libcairo-devel libcares-devel libcurl-devel libfontconfig-devel libfreetype-devel libglib-devel libidn-devel libjpeg-devel liblcms2-devel libnspr-devel libnss-devel libopenjpeg-devel libpng-devel libqt5-devel libssh2-devel libstdc++6-devel libtiff-devel libz-devel vim
Changelog:Sat Jan 11 2020 - silvan (0.84.0-2mamba)
- rebuilt with ENABLE_UNSTABLE_API_ABI_HEADERS=ON
Sat Jan 11 2020 - silvan (0.84.0-1mamba)
- update to 0.84.0
- added debug_package, removed conflicting old postplug update file
Thu Nov 14 2019 - autodist (0.82.0-1mamba)
- automatic version update by autodist
Thu Aug 29 2019 - autodist (0.80.0-1mamba)
- automatic version update by autodist
Sun Aug 26 2018 - silvan (0.67.0-3mamba)
- rebuilt with -DENABLE_XPDF_HEADERS=ON and -DENABLE_GTK_DOC=ON
Tue Aug 21 2018 - silvan (0.67.0-2mamba)
- added -cpp and -cpp-devel packages
Sun Aug 19 2018 - autodist (0.67.0-1mamba)
- automatic version update by autodist
Sat Sep 23 2017 - autodist (0.59.0-1mamba)
- automatic version update by autodist
Tue Aug 08 2017 - autodist (0.57.0-1mamba)
- automatic version update by autodist
Sat Mar 04 2017 - autodist (0.52.0-1mamba)
- automatic version update by autodist
Wed Jan 25 2017 - autodist (0.51.0-1mamba)
- automatic version update by autodist
Sat Dec 17 2016 - autodist (0.50.0-1mamba)
- automatic version update by autodist
Thu Dec 01 2016 - autodist (0.49.0-1mamba)
- automatic version update by autodist
Fri Aug 19 2016 - autodist (0.47.0-1mamba)
- automatic version update by autodist
Mon Aug 08 2016 - autodist (0.46.0-1mamba)
- automatic version update by autodist
Sat Apr 23 2016 - autodist (0.42.0-1mamba)
- automatic version update by autodist
Thu Feb 18 2016 - autodist (0.41.0-1mamba)
- automatic version update by autodist
Wed Feb 03 2016 - autodist (0.40.0-1mamba)
- automatic version update by autodist
Mon Jan 25 2016 - autodist (0.39.0-1mamba)
- automatic version update by autodist
Fri Oct 02 2015 - autodist (0.36.0-1mamba)
- automatic version update by autodist
Thu May 28 2015 - autodist (0.33.0-1mamba)
- automatic version update by autodist
Sat Mar 28 2015 - autodist (0.32.0-1mamba)
- automatic update by autodist
Tue Feb 17 2015 - autodist (0.31.0-1mamba)
- automatic update by autodist
Mon Jan 19 2015 - autodist (0.30.0-1mamba)
- automatic update by autodist
Tue Dec 16 2014 - autodist (0.29.0-1mamba)
- automatic update by autodist
Tue Nov 11 2014 - autodist (0.28.1-1mamba)
- automatic version update by autodist
Sun Sep 28 2014 - autodist (0.26.5-1mamba)
- automatic version update by autodist
Sun Aug 24 2014 - autodist (0.26.4-1mamba)
- automatic version update by autodist
Sun Jul 27 2014 - autodist (0.26.3-1mamba)
- automatic version update by autodist
Sat Jun 28 2014 - autodist (0.26.2-1mamba)
- automatic version update by autodist
Tue May 27 2014 - autodist (0.26.1-1mamba)
- automatic version update by autodist
Fri May 09 2014 - autodist (0.26.0-1mamba)
- automatic version update by autodist
Sat Jan 04 2014 - autodist (0.24.5-1mamba)
- automatic version update by autodist
Sun Dec 01 2013 - autodist (0.24.4-1mamba)
- automatic version update by autodist
Fri Nov 01 2013 - autodist (0.24.3-1mamba)
- automatic version update by autodist
Tue Oct 01 2013 - autodist (0.24.2-1mamba)
- automatic update by autodist
Wed Aug 28 2013 - autodist (0.24.1-1mamba)
- automatic update by autodist
Sun Aug 11 2013 - autodist (0.24.0-1mamba)
- update to 0.24.0
Sat Jul 20 2013 - silvan (0.22.5-1mamba)
- update to 0.22.5
- bump epoch up (downgrade) to fix wrong update to unstable release
- also add postplug update script to force removal of older packages (broken postun script)
Tue Jun 11 2013 - autodist (0.23.2-1mamba)
- update to 0.23.2
Sat May 25 2013 - autodist (0.22.4-1mamba)
- automatic version update by autodist
Sat Apr 13 2013 - autodist (0.22.3-1mamba)
- automatic version update by autodist
Tue Mar 19 2013 - autodist (0.22.2-1mamba)
- automatic version update by autodist
Mon Feb 11 2013 - autodist (0.22.1-1mamba)
- automatic version update by autodist
Wed Jan 09 2013 - autodist (0.22.0-1mamba)
- automatic version update by autodist
Tue Nov 27 2012 - autodist (0.21.2-1mamba)
- automatic version update by autodist
Sat Nov 10 2012 - autodist (0.21.1-1mamba)
- automatic version update by autodist
Tue Oct 16 2012 - autodist (0.21.0-1mamba)
- automatic version update by autodist
Sat Sep 29 2012 - silvan (0.20.4-1mamba)
- update to 0.20.4
Sun Aug 19 2012 - autodist (0.20.3-1mamba)
- automatic version update by autodist
Sun Aug 05 2012 - silvan (0.20.2-1mamba)
- update to 0.20.2
- should fix printing broken in 0.20.1, see http://bot24.blogspot.it/2012/07/linux-bug-426552-upgrade-to-poppler.html
Wed Jun 13 2012 - autodist (0.20.1-1mamba)
- automatic version update by autodist
Sun Jun 26 2011 - autodist (0.17.1-1mamba)
- automatic update by autodist
Fri Feb 18 2011 - autodist (0.16.2-1mamba)
- automatic update by autodist
Fri Jul 02 2010 - silvan (0.14.0-3mamba)
- rebuilt with libpng 1.4
- added --enable-libcurl
Tue Jun 29 2010 - silvan (0.14.0-2mamba)
- disable build of legacy libpoppler3
Tue Jun 29 2010 - autodist (0.14.0-1mamba)
- automatic update by autodist
Sat Jun 05 2010 - autodist (0.13.4-1mamba)
- automatic update by autodist
Thu Dec 03 2009 - silvan (0.12.2-2mamba)
- tools: removed conflict with xpdf
Wed Dec 02 2009 - silvan (0.12.2-1mamba)
- update to 0.12.2
Mon Aug 31 2009 - autodist (0.11.3-1mamba)
- automatic update by autodist
Mon Aug 10 2009 - autodist (0.11.2-1mamba)
- automatic update by autodist
Sat Jul 04 2009 - autodist (0.11.1-1mamba)
- automatic update by autodist
Fri May 29 2009 - autodist (0.11.0-1mamba)
- automatic update by autodist
Tue Apr 28 2009 - autodist (0.10.6-1mamba)
- automatic update by autodist
Thu Apr 16 2009 - silvan (0.10.5-1mamba)
- automatic update by autodist
Mon Mar 02 2009 - silvan (0.10.4-1mamba)
- automatic update by autodist
Sat Jan 03 2009 - silvan (0.10.2-1mamba)
- automatic update by autodist
Wed Dec 03 2008 - silvan (0.10.1-1mamba)
- update to 0.10.1
- remove libpoppler3-qt4 package, same lib API as libpoppler-qt4
Sat Oct 11 2008 - aleph0 (0.10.0-1mamba)
- update to 0.10.0
- poppler-data update to 0.2.1
- add missing %defattr directive
- add build requirements for libopenjpeg-devel
- new compatibility packages libpoppler3, and libpoppler3-qt4
Thu Aug 28 2008 - aleph0 (0.8.6-2mamba)
- create devel packages for libpoppler-qt3 and libpoppler-qt4
Thu Aug 28 2008 - aleph0 (0.8.6-1mamba)
- update to 0.8.6
- do not build the (now unused) libpoppler0, and libpoppler1 libraries
Thu May 08 2008 - aleph0 (0.8.2-1mamba)
- update to 0.8.2
- new compatibility packages libpoppler2, libpoppler2-qt3 and libpoppler2-qt4
Mon Mar 03 2008 - aleph0 (0.6.4-1mamba)
- update to 0.6.4
Fri Jan 11 2008 - aleph0 (0.6.3-1mamba)
- update to 0.6.3
- update poppler-data to 0.2.0
Wed Nov 21 2007 - aleph0 (0.6.2-1mamba)
- update to 0.6.2
- update poppler-data to 0.1.1
- fix CVE-2007-4352, CVE-2007-5392 and CVE-2007-5393
Tue Nov 06 2007 - aleph0 (0.6.1-1mamba)
- update to 0.6.1
- added libpoppler1 and libpoppler1-qt3 subpackages
Sat Feb 24 2007 - silvan (0.5.4-4qilnx)
- enable xpdf headers installation
- added libpoppler0-qt3 subpackage
- removed duplicates of libpoppler0 in libpoppler
Wed Jan 17 2007 - davide (0.5.4-3qilnx)
- new subpackage apidocs with API documentation
Mon Jan 01 2007 - silvan (0.5.4-2qilnx)
- rebuilt with Xorg 7.1
Mon Nov 06 2006 - davide (0.5.4-1qilnx)
- update to version 0.5.4 by autospec
- created new package libpoppler-tools
- added gtk-doc documentation to devel subpackage
- added bindings for QT4
- created the compatibility package libpoppler0
Thu Apr 27 2006 - davide (0.4.5-1qilnx)
- update to version 0.4.5 by autospec
- this version include a fix for CVE-2006-0301
Fri Feb 03 2006 - davide (0.4.4-2qilnx)
- security update for CVE-2006-0301 (qibug#123)
- new package libpoppler-qt
Fri Jan 20 2006 - davide (0.4.4-1qilnx)
- update to version 0.4.4 by autospec
- also fixes the security issues CVE-2005-364[4,5,7] (qibug#114)
Thu Dec 15 2005 - davide (0.4.3-1qilnx)
- update to version 0.4.3 by autospec
- also fixes the security issues CVE-2005-3191 and CAN-2005-2097 (qibug#90)
Thu Sep 01 2005 - davide (0.4.1-1qilnx)
- update to version 0.4.1 by autospec
- several specfile fixes
Wed Jun 22 2005 - Alessandro Ramazzina (0.3.3-2qilnx)
- rebuild and moved from devel-contrib repository to devel repository
Wed Jun 22 2005 - Matteo Bernasconi (0.3.3-1qilnx)
- first build

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.