[repositories] devel: [groups] [packages] [maintainers] [changelog]

 perl-Params-Util: Params::Util - Simple, compact and correct param-checking functions

Name:perl-Params-Util
Release:1.07-3mamba
Architecture:arm
Group:System/Libraries/Perl
Description:Params::Util provides a basic set of importable functions that makes checking parameters a hell of a lot easier

While they can be (and are) used in other contexts, the main point behind this module is that the functions both Do What You Mean, and Do The Right Thing, so they are most useful when you are getting params passed into your code from someone and/or somewhere else and you can't really trust the quality.

Thus, Params::Util is of most use at the edges of your API, where params and data are coming in from outside your code.

The functions provided by Params::Util check in the most strictly correct manner known, are documented as thoroughly as possible so their exact behaviour is clear, and heavily tested so make sure they are not fooled by weird data and Really Bad Things.

To use, simply load the module providing the functions you want to use as arguments (as shown in the SYNOPSIS).

To aid in maintainability, Params::Util will never export by default.

You must explicitly name the functions you want to export, or use the :ALL param to just have it export everything (although this is not recommended if you have any _FOO functions yourself with which future additions to Params::Util may clash)
Size:45.48 KB
Download:perl-Params-Util-1.07-3mamba.arm.rpm
Source RPM:perl-Params-Util
Provides:Util.so perl(Params::Util)[=1.07] perl-Params-Util[=1.07-3mamba]
Requires:ld-linux.so.3 ld-linux.so.3(GLIBC_2.4) libc.so.6 libc.so.6(GLIBC_2.4) perl[>=0:5.00503] perl[>=5.24.0] perl(DynaLoader)(libperl|perl) perl(Exporter) perl(Scalar::Util) perl(overload) perl(strict) perl(vars)
RPM requirements:glibc perl perl(DynaLoader)(libperl|perl) perl libperl perl
Required by:perl-Data-OptList(arm) perl-Moose(arm) perl-Package-DeprecationManager(arm) perl-Sub-Exporter(arm)
Build required by:
Filenames:/usr/lib/perl5/vendor_perl/5.24.0/arm-linux-thread-multi/Params/Util.pm /usr/lib/perl5/vendor_perl/5.24.0/arm-linux-thread-multi/auto/Params/Util /usr/lib/perl5/vendor_perl/5.24.0/arm-linux-thread-multi/auto/Params/Util/Util.so /usr/share/man/man3/Params::Util.3pm.gz

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.