[repositories] devel: [groups] [packages] [maintainers] [changelog]

 perl-UNIVERSAL-require: UNIVERSAL::require - require() modules from a variable

Name:perl-UNIVERSAL-require
Release:0.13-2mamba
Architecture:arm
Group:System/Libraries/Perl
Description:If you've ever had to do this...

eval "require $module";

to get around the bareword caveats on require(), this module is for you. It creates a universal require() class method that will work with every Perl module and its secure. So instead of doing some arcane eval() work, you can do this:

$module->require;

It doesn't save you much typing, but it'll make alot more sense to someone who's not a ninth level Perl acolyte
Size:7.40 KB
Download:perl-UNIVERSAL-require-0.13-2mamba.arm.rpm
Source RPM:perl-UNIVERSAL-require
Provides:perl(UNIVERSAL::require)[=0.13] perl-UNIVERSAL-require[=0.13-2mamba]
Requires:perl[>=5.10.0] perl(strict) perl(vars)
RPM requirements:perl
Required by:
Build required by:
Filenames:/usr/lib/perl5/vendor_perl/5.10.1/UNIVERSAL/require.pm /usr/lib/perl5/vendor_perl/5.10.1/arm-linux-thread-multi/auto/UNIVERSAL/require /usr/share/man/man3/UNIVERSAL::require.3pm.gz

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.