packages subversion-1.6.0-deplibs.patch
      Pages: < 1 >  DOWNLOAD      
--- subversion-1.6.0/build/ac-macros/apr.m4.deplibs
+++ subversion-1.6.0/build/ac-macros/apr.m4
@@ -76,9 +76,9 @@ AC_DEFUN(SVN_LIB_APR,
 
   dnl When APR stores the dependent libs in the .la file, we don't need 
   dnl --libs.
-  SVN_APR_LIBS="`$apr_config --link-libtool --libs`"
+  SVN_APR_LIBS="`$apr_config --link-libtool`"
   if test $? -ne 0; then
-    AC_MSG_ERROR([apr-config --link-libtool --libs failed])
+    AC_MSG_ERROR([apr-config --link-libtool failed])
   fi
 
   SVN_APR_EXPORT_LIBS="`$apr_config --link-ld --libs`"
--- subversion-1.6.0/build/ac-macros/aprutil.m4.deplibs
+++ subversion-1.6.0/build/ac-macros/aprutil.m4
@@ -77,11 +77,9 @@ AC_DEFUN(SVN_LIB_APRUTIL,
     AC_MSG_ERROR([apu-config --prefix failed])
   fi
 
-  dnl When APR stores the dependent libs in the .la file, we don't need
-  dnl --libs.
-  SVN_APRUTIL_LIBS="`$apu_config --link-libtool --libs`"
+  SVN_APRUTIL_LIBS="`$apu_config --link-libtool`"
   if test $? -ne 0; then
-    AC_MSG_ERROR([apu-config --link-libtool --libs failed])
+    AC_MSG_ERROR([apu-config --link-libtool failed])
   fi
 
   SVN_APRUTIL_EXPORT_LIBS="`$apu_config --link-ld --libs`"