packages gnome-autoar.spec
      Pages: < 1 >  DOWNLOAD      
Name:          gnome-autoar
Version:       0.2.3
Epoch:         1
Release:       1mamba
Summary:       Automatic archives creating and extracting library
Group:         System/Libraries
Vendor:        openmamba
Distribution:  openmamba
Packager:      Silvan Calarco <silvan.calarco@...>
URL:           https://github.com/GNOME/gnome-autoar
## GITSOURCE https://github.com/GNOME/gnome-autoar.git master
Source:        https://github.com/GNOME/gnome-autoar.git/%{version}/gnome-autoar-%{version}.tar.bz2
License:       LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libacl-devel
BuildRequires: libarchive-devel
BuildRequires: libatk-devel
BuildRequires: libblkid-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
BuildRequires: libexpat-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libgraphite2-devel
BuildRequires: libgtk-devel
BuildRequires: libharfbuzz-devel
BuildRequires: liblzma-devel
BuildRequires: libmount-devel
BuildRequires: libnettle-devel
BuildRequires: libopenssl-devel
BuildRequires: libpango-devel
BuildRequires: libpcre-devel
BuildRequires: libpng-devel
BuildRequires: libselinux-devel
BuildRequires: libsepol-devel
BuildRequires: libthai-devel
BuildRequires: libuuid-devel
BuildRequires: libxml2-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
Requires:      lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot:     %{_tmppath}/%{name}-%{version}-root

%description
Automatic archives creating and extracting library.

%package -n lib%{name}
Group:         System/Libraries
Summary:       Automatic archives creating and extracting library

%description -n lib%{name}
Automatic archives creating and extracting library.

%package -n lib%{name}-devel
Group:         Development/Libraries
Summary:       Development files for %{name}
Requires:      lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires:      pkg-config

%description -n lib%{name}-devel
This package contains libraries and header files for developing applications that use %{name}.

%debug_package

%prep
%setup -q

%build
./autogen.sh
%configure
%make

%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall

%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"

%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig

%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libgnome-autoar-0.so.*
%{_libdir}/libgnome-autoar-gtk-0.so.*
%{_libdir}/girepository-1.0/GnomeAutoar-0.1.typelib
%{_libdir}/girepository-1.0/GnomeAutoarGtk-0.1.typelib

%files -n lib%{name}-devel
%defattr(-,root,root)
%dir %{_includedir}/gnome-autoar-0
%dir %{_includedir}/gnome-autoar-0/gnome-autoar
%{_includedir}/gnome-autoar-0/gnome-autoar/*.h
%{_libdir}/libgnome-autoar-0.a
%{_libdir}/libgnome-autoar-0.la
%{_libdir}/libgnome-autoar-0.so
%{_libdir}/libgnome-autoar-gtk-0.a
%{_libdir}/libgnome-autoar-gtk-0.la
%{_libdir}/libgnome-autoar-gtk-0.so
%{_libdir}/pkgconfig/gnome-autoar-0.pc
%{_libdir}/pkgconfig/gnome-autoar-gtk-0.pc
%{_datadir}/vala/vapi/gnome-autoar-0.vapi
%{_datadir}/vala/vapi/gnome-autoar-gtk-0.vapi
%{_datadir}/gir-1.0/GnomeAutoar-0.1.gir
%{_datadir}/gir-1.0/GnomeAutoarGtk-0.1.gir

%changelog
* Mon Mar 12 2018 Automatic Build System <autodist@...> 0.2.3-1mamba
- automatic version update by autodist

* Sun Jul 16 2017 Silvan Calarco <silvan.calarco@...> 0.2.2-1mamba
- update to 0.2.2

* Mon Apr 27 2015 Silvan Calarco <silvan.calarco@...> 20150427git-1mamba
- package created using the webbuild interface