openmamba logo
GNU/Linux distribution
general information distribution forum community wiki bugs events
info   software   forum community wiki bugs events
packages libreoffice-3.3.0.4-lucene-bundleversion.patch
      Pages: < 1 >  DOWNLOAD      
--- configure.in	2011-01-25 06:17:31.000000000 +0100
+++ configure.in-gil	2011-01-25 06:20:15.000000000 +0100
@@ -4342,8 +4342,8 @@
         AC_MSG_RESULT([external])
         SYSTEM_LUCENE=YES
         if test -z $LUCENE_CORE_JAR; then
-          AC_CHECK_FILE(/usr/share/java/lucene-core-2.3.jar,
-            [ LUCENE_CORE_JAR=/usr/share/java/lucene-core-2.3.jar ],
+          AC_CHECK_FILE(/usr/share/java/lucene-core-2.4.1.jar,
+            [ LUCENE_CORE_JAR=/usr/share/java/lucene-core-2.4.1.jar ],
             [
               AC_CHECK_FILE(/usr/share/java/lucene-core.jar,
                 [ LUCENE_CORE_JAR=/usr/share/java/lucene-core.jar ],
@@ -4361,8 +4361,8 @@
         fi
 
         if test -z $LUCENE_ANALYZERS_JAR; then
-          AC_CHECK_FILE(/usr/share/java/lucene-analyzers-2.3.jar,
-            [ LUCENE_ANALYZERS_JAR=/usr/share/java/lucene-analyzers-2.3.jar ],
+          AC_CHECK_FILE(/usr/share/java/lucene-contrib/lucene-analyzers-2.4.1.jar,
+            [ LUCENE_ANALYZERS_JAR=/usr/share/java/lucene-contrib/lucene-analyzers-2.4.1.jar ],
             [
               AC_CHECK_FILE(/usr/share/java/lucene-contrib/lucene-analyzers.jar,
                 [ LUCENE_ANALYZERS_JAR=/usr/share/java/lucene-contrib/lucene-analyzers.jar ],
@@ -4374,13 +4374,13 @@
           AC_CHECK_FILE($LUCENE_CORE_JAR, [],
                [ AC_MSG_ERROR(lucene-analyzers.jar not found.)], [])
         fi
-        AC_MSG_CHECKING([whether lucene is version 2.x])
+        AC_MSG_CHECKING([whether lucene is version 1.9.1.x])
         export LUCENE_CORE_JAR
         if $PERL -e 'use Archive::Zip;
             my $file = "$ENV{'LUCENE_CORE_JAR'}";
             my $zip = Archive::Zip->new( $file );
             my $mf = $zip->contents ( "META-INF/MANIFEST.MF" );
-            if ( $mf =~ m/Specification-Version: 2.*/ ) {
+            if ( $mf =~ m/Bundle-Version: 1.9.1.*/ ) {
                 exit 0;
             } else {
                 exit 1;