[repositories] devel: [groups] [packages] [maintainers] [changelog]

 libpcre: PCRE is a Perl-compatible regular expression library

Name:libpcre
Release:8.43-1mamba
Architecture:x86_64
Group:System/Libraries
Description:PCRE has its own native API, but a set of "wrapper" functions that are based on the POSIX API are also supplied in the library libpcreposix.
Note that this just provides a POSIX calling interface to PCRE: the regular expressions themselves still follow Perl syntax and semantics.
The header file for the POSIX-style functions is called pcreposix.h.
The official POSIX name is regex.h, but I didn't want to risk possible problems with existing files of that name by distributing it that way.
To use it with an existing program that uses the POSIX API, it will have to be renamed or pointed at by a link.
Size:984.43 KB
Download:libpcre-8.43-1mamba.x86_64.rpm
Source RPM:libpcre
Provides:libpcre.so.1()(64bit) libpcre.so.3 libpcre16.so.0()(64bit) libpcre3 libpcre32.so.0()(64bit) libpcrecpp.so.0()(64bit) libpcreposix.so.0()(64bit) libpcre[=8.43-1mamba]
Requires:/sbin/ldconfig(ldconfig|ldconfig-multilib) /sbin/ldconfig(ldconfig|ldconfig-multilib) libbz2.so.1.0()(64bit) libc.so.6()(64bit) libc.so.6(GLIBC_2.14)(64bit) libc.so.6(GLIBC_2.2.5)(64bit) libc.so.6(GLIBC_2.3)(64bit) libgcc_s.so.1()(64bit)(libgcc|libgcc6) libgcc_s.so.1(GCC_3.0)(64bit)(libgcc|libgcc6) libm.so.6()(64bit) libncurses.so.6()(64bit) libpcre.so.1()(64bit) libpcre16.so.0()(64bit) libpcre32.so.0()(64bit) libpcreposix.so.0()(64bit) libreadline.so.7()(64bit) libstdc++.so.6()(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3)(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3.9)(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4)(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.20)(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.21)(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.9)(64bit)(gcc6-c++|libstdc++6) libz.so.1()(64bit)
RPM requirements:/sbin/ldconfig(ldconfig|ldconfig-multilib) libbzip2 glibc libgcc_s.so.1()(64bit)(libgcc|libgcc6) libgcc_s.so.1(GCC_3.0)(64bit)(libgcc|libgcc6) glibc libncurses libreadline7 libstdc++.so.6()(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3)(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(CXXABI_1.3.9)(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4)(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.20)(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.21)(64bit)(gcc6-c++|libstdc++6) libstdc++.so.6(GLIBCXX_3.4.9)(64bit)(gcc6-c++|libstdc++6) libz
Required by:abiword(x86_64) aircrack-ng(x86_64) anjuta(x86_64) apache(x86_64) audacity(x86_64) avahi(x86_64) avahi-compat-howl(x86_64) avahi-compat-libdns_sd(x86_64) avrdude(x86_64) brasero(x86_64) ccnet-server(x86_64) ccze(x86_64) cheese(x86_64) cinnamon(x86_64) cjs(x86_64) claws-mail(x86_64) clutter-gst(x86_64) clutter-gtk(x86_64) cnijfilter4-mg2500series(x86_64) codeblocks(x86_64) cyrus-imapd(x86_64) dpkg(x86_64) dvdauthor(x86_64) empathy(x86_64) enchant1(x86_64) enchant1-aspell(x86_64) enchant1-voikko(x86_64) evince(x86_64) falcon(x86_64) farstream(x86_64) flatpak(x86_64) florence(x86_64) fontconfig(x86_64) fontforge(x86_64) freefilesync(x86_64) freeradius-server(x86_64) fwts(x86_64) gambas2-gb-pcre(x86_64) gambas3-gb-cairo(x86_64) gambas3-gb-dbus(x86_64) gambas3-gb-desktop(x86_64) gambas3-gb-gtk(x86_64) gambas3-gb-gtk3(x86_64) gambas3-gb-image(x86_64) gambas3-gb-media(x86_64) gambas3-gb-mime(x86_64) gambas3-gb-pcre(x86_64) ganglia(x86_64) gconfmm(x86_64) gda(x86_64) gdm(x86_64) geany(x86_64) gedit(x86_64) geoclue(x86_64) geoclue0(x86_64) gerbv(x86_64) gjs(x86_64) gnome-keyring(x86_64) gnome-keyring-devel(x86_64) gnome-online-accounts(x86_64) gnome-system-log(x86_64) gnome-terminal(x86_64) gnome-themes-standard(x86_64) gnome-utils(x86_64) gnucash(x86_64) gource(x86_64) GraphicsMagick(x86_64) graphviz(x86_64) grep(x86_64) gsmartcontrol(x86_64) gst-plugins-bad(x86_64) gst-plugins-bad010(x86_64) gstreamer-tools(x86_64) gtk-vnc(x86_64) gutenprint(x86_64) gwenhywfar(x86_64) handbrake(x86_64) harfbuzz(x86_64) hexchat(x86_64) hfst-ospell(x86_64) hplip(x86_64) ImageMagick(x86_64) ImageMagick69(x86_64) intel-gpu-tools(x86_64) iproute(x86_64) irssi(x86_64) jamin(x86_64) kdelibs(x86_64) kdelibs3(x86_64) kino(x86_64) kodi(x86_64) kommander(x86_64) libaccounts-glib(x86_64) libaccounts-glib-devel(x86_64) libaccounts-glib-tools(x86_64) libamtk(x86_64) libappindicator(x86_64) libappindicator3(x86_64) libass(x86_64) libavahi(x86_64) libavahi-glib(x86_64) libavahi-gtk3(x86_64) libavahi-qt3(x86_64) libblockdev(x86_64) libblockdev-tools(x86_64) libcacard(x86_64) libcairo-tools(x86_64) libcanberra(x86_64) libcanberra-gtk2(x86_64) libcanberra-gtk3(x86_64) libcaribou(x86_64) libcaribou-gtk2(x86_64) libccnet(x86_64) libcjs(x86_64) libclutter(x86_64) libcodeblocks(x86_64) libcogl(x86_64) libcroco(x86_64) libdbus-glib(x86_64) libdbus-glib-tools(x86_64) libdc1394(x86_64) libempathy(x86_64) libenchant1(x86_64) libflatpak(x86_64) libfm(x86_64) libfontconfig(x86_64) libfontforge(x86_64) libfreeradius(x86_64) libfreetype(x86_64) libftgl(x86_64) libfwts(x86_64) libgames-support(x86_64) libganglia(x86_64) libgarcon(x86_64) libgcj4(x86_64) libgcr(x86_64) libgd(x86_64) libgd-utils(x86_64) libgda(x86_64) libgda-mysql(x86_64) libgda-postgresql(x86_64) libgdal(x86_64) libgdata(x86_64) libgdiplus(x86_64) libgdk-pixbuf(x86_64) libgdk-pixbuf-devel(x86_64) libgdl(x86_64) libgeany(x86_64) libgegl(x86_64) libgegl02(x86_64) libgjs(x86_64) libgksu(x86_64) libglib(x86_64) libgmime(x86_64) libgnome-autoar(x86_64) libgnome-games-support(x86_64) libgnome-vfs(x86_64) libgnomekbd(x86_64) libgoffice08(x86_64) libgoocanvas(x86_64) libgphoto2(x86_64) libGraphicsMagick(x86_64) libgraphviz(x86_64) libgraphviz-tcl(x86_64) libgspell(x86_64) libgspell-devel(x86_64) libgst-plugins-base(x86_64) libgstreamer(x86_64) libgtk(x86_64) libgtk-devel(x86_64) libgtk2(x86_64) libgtk2-devel(x86_64) libgtksourceview(x86_64) libgtkspell3(x86_64) libgtop(x86_64) libgtop10(x86_64) libguestfs(x86_64) libgupnp-igd(x86_64) libgvfs(x86_64) libharfbuzz(x86_64) libhfstospell(x86_64) libhidapi(x86_64) libimlib2(x86_64) libimlib2-devel(x86_64) libimlib2-filters(x86_64) libimlib2-loaders(x86_64) libkjs(x86_64) liblangtag(x86_64) libMagick(x86_64) libMagick69(x86_64) libmbim(x86_64) libmbim-tools(x86_64) libmuffin(x86_64) libmypaint(x86_64) libmysqlclient(x86_64) libnautilus-extension-sendto(x86_64) libnice(x86_64) libnm(x86_64) libnm-gtk(x86_64) libopensc(x86_64) libosinfo(x86_64) libosinfo-tools(x86_64) libostree(x86_64) libpcre-devel(x86_64) libpcre0-devel(x86_64) libphodav(x86_64) libpolkit(x86_64) libpstoedit(x86_64) libpulseaudio-glib(x86_64) libqalculate5(x86_64) libqalculate7(x86_64) libqmi(x86_64) libqmi-tools(x86_64) librasqal(x86_64) librest(x86_64) librsvg(x86_64) libsane-backends(x86_64) libscim(x86_64) libSDL2_ttf(x86_64) libseafile(x86_64) libsearpc(x86_64) libsecret(x86_64) libsecret-tools(x86_64) libselinux(x86_64) libselinux-tools(x86_64) libsignon-glib(x86_64) libspeechd(x86_64) libspice(x86_64) libspice-gtk(x86_64) libsyslog-ng(x86_64) libtotem-pl-parser(x86_64) libtracker(x86_64) libuhttpmock(x86_64) libumockdev(x86_64) libunity(x86_64) libunity-tools(x86_64) libvirt(x86_64) libvirt-client(x86_64) libvirt-glib(x86_64) libvlc(x86_64) libvolume_key(x86_64) libvte(x86_64) libwacom(x86_64) libwebkit-gtk3(x86_64) libwxsvg(x86_64) libxfce4ui(x86_64) libxfconf(x86_64) libXft(x86_64) libyelp(x86_64) libzeitgeist2(x86_64) lighttpd(x86_64) linphone(x86_64) maildrop(x86_64) mariadb(x86_64) mariadb-client(x86_64) mc(x86_64) ModemManager(x86_64) mongodb(x86_64) mongodb-server(x86_64) muffin(x86_64) nautilus-actions(x86_64) network-manager-applet(x86_64) NetworkManager(x86_64) NetworkManager-openconnect(x86_64) NetworkManager-openvpn(x86_64) NetworkManager-pptp(x86_64) NetworkManager-vpnc(x86_64) nginx(x86_64) njb-tools(x86_64) nmap(x86_64) ocaml-pcre(x86_64) octave(x86_64) openocd(x86_64) opensc(x86_64) ostree(x86_64) PackageKit(x86_64) PackageKit-gtk(x86_64) PackageKit-gtk2(x86_64) phodav(x86_64) php(x86_64) pkg-config(x86_64) plymouth(x86_64) plymouth-x11(x86_64) postfix(x86_64) postgis(x86_64) pstoedit(x86_64) pulseaudio-module-gsettings(x86_64) pulseaudio-module-zeroconf(x86_64) pygobject2(x86_64) python-appindicator(x86_64) qalculate5(x86_64) qalculate7(x86_64) R(x86_64) readpst(x86_64) rhythmbox(x86_64) rhythmbox-devel(x86_64) rrdtool(x86_64) rsyslog(x86_64) sane(x86_64) sarg(x86_64) seafile(x86_64) seafile-server(x86_64) snort(x86_64) sord(x86_64) speech-dispatcher(x86_64) spice-gtk(x86_64) subversion(x86_64) swig(x86_64) syslog-ng(x86_64) telepathy-farstream(x86_64) telepathy-gabble(x86_64) telepathy-mission-control(x86_64) texlive(x86_64) texlive-xdvi(x86_64) Thunar(x86_64) tracker(x86_64) udisks2(x86_64) umockdev(x86_64) usbmuxd(x86_64) volume_key(x86_64) wget(x86_64) xarchiver(x86_64) xfce4-panel(x86_64) xorg-server(x86_64) xorg-server-dmx(x86_64) yelp(x86_64) zeitgeist(x86_64)
Build required by:
Filenames:/usr/bin/pcregrep /usr/bin/pcretest /usr/lib64/libpcre.so.1 /usr/lib64/libpcre.so.1.2.11 /usr/lib64/libpcre.so.3 /usr/lib64/libpcre16.so.0 /usr/lib64/libpcre16.so.0.2.11 /usr/lib64/libpcre32.so.0 /usr/lib64/libpcre32.so.0.0.11 /usr/lib64/libpcrecpp.so.0 /usr/lib64/libpcrecpp.so.0.0.1 /usr/lib64/libpcreposix.so.0 /usr/lib64/libpcreposix.so.0.0.6 /usr/lib64/libpcreposix.so.3 /usr/share/doc/libpcre-8.43 /usr/share/doc/libpcre-8.43/AUTHORS /usr/share/doc/libpcre-8.43/LICENCE /usr/share/man/man1/pcre-config.1.gz /usr/share/man/man1/pcregrep.1.gz /usr/share/man/man1/pcretest.1.gz

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.