[repositories] devel: [groups] [packages] [maintainers] [changelog]

 PackageKit: A system designed to make installing and updating software on your computer easier (source)

Name:PackageKit
Release:1.1.12-7mamba
Group:System/Management
Maintainer:silvan
Description:PackageKit is a system designed to make installing and updating software on your computer easier. The primary design goal is to unify all the software graphical tools used in different distributions, and use some of the latest technology like PolicyKit to make the process suck less.
License:GPL
Size:1.42 MB
Download:PackageKit-1.1.12-7mamba.src.rpm
URL:http://www.packagekit.org
Specfile:PackageKit.spec
Sources:PackageKit-1.1.12.tar.xz
Patches:PackageKit-0.6.6-openmamba-groups.patch PackageKit-1.1.6-openmamba-Vendor.conf.patch PackageKit-0.6.9-command_not_found_raise_timeout.patch PackageKit-0.9.1-smart-what_provides.patch PackageKit-0.6.13-smartBackend_fix_best_package.patch PackageKit-0.6.13-smartBackend_fix_Changelog.patch PackageKit-0.6.13-qt_fix_searchGroups.patch PackageKit-0.6.13-pk-transaction_fix_crash.patch PackageKit-0.8.7-smartBackend-fix_trust_and_upgrade.patch PackageKit-0.6.21-xulrunner-7.patch PackageKit-0.6.21-revert_utf8_for_smart.patch PackageKit-0.6.22-display_smart_errors_as_html.patch PackageKit-0.8.11-smartBackend-fix-remove-packages.patch PackageKit-0.9.5-smartBackend-correctly-raise-exceptions.patch PackageKit-1.1.6-yumBackend-override_sigchecks.patch PackageKit-1.1.12-dnf-openmamba.patch PackageKit-1.1.12-dnf-repos-dir.patch PackageKit-1.1.12-dnf-disable-trusted-packages-check.patch PackageKit-1.1.12-upstream-dnf-invalidate-the-sack-cache-after-downloading-new-metadata.patch 
Build time:Thu Aug 15 2019
Built RPMS:PackageKit(i586) PackageKit-debug(i586) PackageKit-glib(i586) PackageKit-glib-devel(i586) PackageKit-gtk(i586) PackageKit-gtk2(i586) PackageKit(arm) PackageKit-debug(arm) PackageKit-glib(arm) PackageKit-glib-devel(arm) PackageKit-gtk(arm) PackageKit-gtk2(arm) PackageKit(x86_64) PackageKit-debug(x86_64) PackageKit-glib(x86_64) PackageKit-glib-devel(x86_64) PackageKit-gtk(x86_64) PackageKit-gtk2(x86_64)
Build requirements:glibc-devel gobject-introspection-devel libappstream-glib-devel libatk-devel libbeecrypt-devel libblkid-devel libbzip2-devel libcairo-devel libcppunit-devel libcpuinfo-devel libdnf[>=0.31.0] libdnf-devel libdw-devel libe2fs-devel libelf-devel libexpat-devel libffi-devel libfontconfig-devel libfreetype-devel libfribidi-devel libgcc libgdk-pixbuf-devel libglib-devel libgraphite2-devel libgstreamer-devel libgtk-devel libgtk2-devel libharfbuzz-devel libkrb5-devel liblzma-devel libmagic-devel libmount-devel libneon-devel libopenssl-devel libpango-devel libpcre-devel libpng-devel libpolkit-devel libpopt-devel libproxy-devel librepo[>=1.10.3] librepo-devel librpm-devel[>=1:4.14.2.1] libselinux-devel libsepol-devel libsqlite-devel libstdc++6-devel libsyck-devel libsystemd-devel libthai-devel libunwind-devel libuuid-devel libz-devel pm-utils-devel
Changelog:Thu Aug 15 2019 - silvan (1.1.12-7mamba)
- removed invalid systemd post etc. scripts
Wed Jul 10 2019 - silvan (1.1.12-6mamba)
- dnf backend: added upstream patch to invalidate cache metadata and possibly fix repo refresh
Sun Jun 23 2019 - silvan (1.1.12-5mamba)
- dns: added patch to disable trusted packages check
Sat Jun 22 2019 - silvan (1.1.12-4mamba)
- rebuilt with rpm 4
Tue Jun 04 2019 - silvan (1.1.12-3mamba)
- fix for openmamba dnf backend patch and configure arguments
- added patch to use /etc/yum/repos.d instead of /etc/yum.repos.d
Sat Jun 01 2019 - silvan (1.1.12-2mamba)
- rebuilt with dnf support instead of broken yum
Fri Dec 28 2018 - silvan (1.1.12-1mamba)
- update to 1.1.12
Thu Nov 30 2017 - autodist (1.1.7-1mamba)
- automatic update by autodist
Wed Nov 15 2017 - silvan (1.1.6-2mamba)
- yum backend: patched to enable overriding signature checks
Sat Aug 26 2017 - silvan (1.1.6-1mamba)
- update to 1.1.6
Sat Aug 26 2017 - silvan (0.9.5-4mamba)
- rebuilt with yum as default backend
Tue Aug 18 2015 - silvan (0.9.5-3mamba)
- provide directory /var/cache/PackgeKit/downloads
- smartBackend.py: patched to raise correct exceptions, hopefully fixes pk lockups on errors
Sat Aug 15 2015 - silvan (0.9.5-2mamba)
- rebuilt on itself to fix requirements for mozilla plugin
Fri Aug 14 2015 - silvan (0.9.5-1mamba)
- update to 0.9.5
Wed Oct 08 2014 - silvan (0.8.17-1mamba)
- update to 0.8.17
Mon Sep 23 2013 - silvan (0.8.11-2mamba)
- smart backend: added a patch to fix remove-packages function
Sun Sep 08 2013 - autodist (0.8.11-1mamba)
- automatic update by autodist
Tue Aug 06 2013 - silvan (0.8.9-2mamba)
- git typelib files moved from -devel to main packages
Sun Jun 30 2013 - autodist (0.8.9-1mamba)
- automatic version update by autodist
Wed Mar 06 2013 - silvan (0.8.7-3mamba)
- reapply smartbackend patch to disable packages trust and fix upgrade
- also port patch to display errors as html in apper
Wed Mar 06 2013 - silvan (0.8.7-2mamba)
- rebuilt using python 2.7
Sat Mar 02 2013 - autodist (0.8.7-1mamba)
- automatic version update by autodist
Fri Dec 07 2012 - autodist (0.7.6-1mamba)
- automatic version update by autodist
Tue Aug 21 2012 - silvan (0.7.4-1mamba)
- update to 0.7.4
Tue Aug 07 2012 - silvan (0.6.22-1mamba)
- update to 0.6.22
Mon Apr 09 2012 - silvan (0.6.21-3mamba)
- rebuilt after moving libattr
Mon Dec 12 2011 - silvan (0.6.21-2mamba)
- cleaned some debugging code in the smart backend patches
- revert utf-8 changes in backend.py to workaround smart backend not working anymore
Mon Dec 12 2011 - silvan (0.6.21-1mamba)
- update to 0.6.21
Mon Dec 12 2011 - silvan (0.6.19-1mamba)
- update to 0.6.19
Mon Dec 12 2011 - silvan (0.6.20-1mamba)
- update to 0.6.20
Mon Jul 25 2011 - autodist (0.6.16-1mamba)
- update to 0.6.16
Sun Jun 19 2011 - autodist (0.6.15-1mamba)
- automatic update by autodist
Wed May 04 2011 - silvan (0.6.14-1mamba)
- update to 0.6.14
- added PackageKit-qt2 from upstream
- split devel packages
- rebuild with NetworkManager and instrospection support
Mon Apr 25 2011 - silvan (0.6.13-3mamba)
- SmartBackend: added patch to fix upgrade and disable trust check because it is not supported
Sun Apr 24 2011 - silvan (0.6.13-2mamba)
- smart backend: revert a patch that disables What-Provides function (http://cgit.freedesktop.org/packagekit/patch/?id=1184745dd4e4597839b5e595d23b0816ff54c3d0)
- smartBackend.py: added patch to fix best install choice by preferring already installed packages for virtual provides
- smartBackend.py: added patch to fix error on ChangeLog parsing
- packagekit-qt: added upstream patch to fix searchGroups function
Sun Apr 24 2011 - silvan (0.6.13-1mamba)
- update to 0.6.13
Sat Mar 05 2011 - silvan (0.6.12-1mamba)
- update to 0.6.12
Wed Jan 12 2011 - autodist (0.6.9-2mamba)
- automatic update by autodist
Thu Oct 07 2010 - silvan (0.6.9-1mamba)
- update to 0.6.9
Wed Oct 06 2010 - silvan (0.6.8-2mamba)
- rebuilt with --disable-networkmanager
Wed Oct 06 2010 - silvan (0.6.8-1mamba)
- update to 0.6.8
Tue Aug 24 2010 - silvan (0.6.7-1mamba)
- update to 0.6.7
Sat Jul 24 2010 - silvan (0.6.6-1mamba)
- update to 0.6.6
- added a patch that adds matches between openmamba groups and PackageKit ones
- added patch to configure Vendor.conf for openmamba
Wed Jun 02 2010 - silvan (0.6.5-1mamba)
- update to 0.6.5
Sat Apr 03 2010 - silvan (0.6.3-1mamba)
- update to 0.6.3
Mon Mar 15 2010 - silvan (0.6.2-1mamba)
- package created by autospec

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.