[repositories] devel: [groups] [packages] [maintainers] [changelog]

 libblockdev: A C library supporting GObject Introspection for manipulation of block devices

Name:libblockdev
Release:2.22-1mamba
Architecture:x86_64
Group:System/Libraries
Description:libblockdev is a C library supporting GObject Introspection for manipulation of block devices. It has a plugin-based architecture where each technology (like LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly with multiple implementations (e.g. using LVM CLI or the new LVM DBus API).
Size:900.26 KB
Download:libblockdev-2.22-1mamba.x86_64.rpm
Source RPM:libblockdev
Provides:libbd_btrfs.so.2()(64bit) libbd_crypto.so.2()(64bit) libbd_dm.so.2()(64bit) libbd_fs.so.2()(64bit) libbd_kbd.so.2()(64bit) libbd_loop.so.2()(64bit) libbd_lvm-dbus.so.2()(64bit) libbd_lvm.so.2()(64bit) libbd_mdraid.so.2()(64bit) libbd_mpath.so.2()(64bit) libbd_nvdimm.so.2()(64bit) libbd_part.so.2()(64bit) libbd_part_err.so.2()(64bit) libbd_swap.so.2()(64bit) libbd_utils.so.2()(64bit) libbd_vdo.so.2()(64bit) libblockdev.so.2()(64bit) libblockdev[=2.22-1mamba]
Requires:/sbin/ldconfig(ldconfig|ldconfig-multilib) /sbin/ldconfig(ldconfig|ldconfig-multilib) ld-linux-x86-64.so.2()(64bit) ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) libassuan.so.0()(64bit) libbd_part_err.so.2()(64bit) libbd_utils.so.2()(64bit) libblkid.so.1()(64bit) libblkid.so.1(BLKID_2.15)(64bit) libblkid.so.1(BLKID_2.17)(64bit) libblkid.so.1(BLKID_2.21)(64bit) libbytesize.so.1()(64bit) libc.so.6()(64bit) libc.so.6(GLIBC_2.2.5)(64bit) libc.so.6(GLIBC_2.27)(64bit) libc.so.6(GLIBC_2.3)(64bit) libc.so.6(GLIBC_2.6)(64bit) libc.so.6(GLIBC_2.7)(64bit) libcryptsetup.so.12()(64bit) libcryptsetup.so.12(CRYPTSETUP_2.0)(64bit) libdaxctl.so.1()(64bit) libdevmapper.so.1.02()(64bit) libdevmapper.so.1.02(Base)(64bit) libdevmapper.so.1.02(DM_1_02_97)(64bit) libdl.so.2()(64bit) libdl.so.2(GLIBC_2.2.5)(64bit) libdmraid.so.1()(64bit) libdmraid.so.1(Base)(64bit) libffi.so.6()(64bit) libgio-2.0.so.0()(64bit) libglib-2.0.so.0()(64bit) libgmodule-2.0.so.0()(64bit) libgmp.so.10()(64bit) libgobject-2.0.so.0()(64bit) libgpg-error.so.0()(64bit) libgpgme.so.11()(64bit) libkmod.so.2()(64bit) libkmod.so.2(LIBKMOD_5)(64bit) libm.so.6()(64bit) libm.so.6(GLIBC_2.2.5)(64bit) libm.so.6(GLIBC_2.29)(64bit) libmount.so.1()(64bit) libmount.so.1(MOUNT_2.19)(64bit) libmount.so.1(MOUNT_2.21)(64bit) libmount.so.1(MOUNT_2.22)(64bit) libmount.so.1(MOUNT_2.30)(64bit) libmpfr.so.6()(64bit) libndctl.so.6()(64bit) libndctl.so.6(LIBNDCTL_1)(64bit) libndctl.so.6(LIBNDCTL_3)(64bit) libnspr4.so()(64bit) libnss3.so()(64bit) libnss3.so(NSS_3.2)(64bit) libnss3.so(NSS_3.9.2)(64bit) libnssutil3.so()(64bit) libparted-fs-resize.so.0()(64bit) libparted-fs-resize.so.0(LIBPARTED_FS_RESIZE_0.0.0)(64bit) libparted.so.2()(64bit) libpcre.so.1()(64bit) libpcre2-8.so.0()(64bit) libplc4.so()(64bit) libplds4.so()(64bit) libpthread.so.0()(64bit) libpthread.so.0(GLIBC_2.2.5)(64bit) libresolv.so.2()(64bit) librt.so.1()(64bit) libselinux.so.1()(64bit) libsepol.so.1()(64bit) libsmime3.so()(64bit) libsmime3.so(NSS_3.4)(64bit) libssl3.so()(64bit) libudev.so.1()(64bit) libudev.so.1(LIBUDEV_183)(64bit) libuuid.so.1()(64bit) libuuid.so.1(UUID_1.0)(64bit) libvolume_key.so.1()(64bit) libyaml-0.so.2()(64bit) libz.so.1()(64bit) python(abi)(python26|python27|python3|python3|python33|python33|python36)[=2.7]
RPM requirements:/sbin/ldconfig(ldconfig|ldconfig-multilib) glibc libassuan libblkid libbytesize glibc libcryptsetup libndctl libdevmapper glibc libdmraid libffi libglib libgmp libglib libgpg-error libgpgme libkmod glibc libmount libmpfr libndctl libnspr libnss libparted libpcre libpcre2 libnspr glibc libselinux libsepol libnss libudev libuuid libvolume_key libyaml libz python(abi)(python26|python27|python3|python3|python33|python33|python36)
Required by:libblockdev-devel(x86_64) libblockdev-tools(x86_64) udisks2(x86_64)
Build required by:
Filenames:/etc/libblockdev /etc/libblockdev/conf.d /etc/libblockdev/conf.d/00-default.cfg /etc/libblockdev/conf.d/10-lvm-dbus.cfg /usr/lib64/girepository-1.0/BlockDev-2.0.typelib /usr/lib64/libbd_btrfs.so.2 /usr/lib64/libbd_btrfs.so.2.0.0 /usr/lib64/libbd_crypto.so.2 /usr/lib64/libbd_crypto.so.2.0.0 /usr/lib64/libbd_dm.so.2 /usr/lib64/libbd_dm.so.2.0.0 /usr/lib64/libbd_fs.so.2 /usr/lib64/libbd_fs.so.2.0.0 /usr/lib64/libbd_kbd.so.2 /usr/lib64/libbd_kbd.so.2.0.0 /usr/lib64/libbd_loop.so.2 /usr/lib64/libbd_loop.so.2.0.0 /usr/lib64/libbd_lvm-dbus.so.2 /usr/lib64/libbd_lvm-dbus.so.2.0.0 /usr/lib64/libbd_lvm.so.2 /usr/lib64/libbd_lvm.so.2.0.0 /usr/lib64/libbd_mdraid.so.2 /usr/lib64/libbd_mdraid.so.2.0.0 /usr/lib64/libbd_mpath.so.2 /usr/lib64/libbd_mpath.so.2.0.0 /usr/lib64/libbd_nvdimm.so.2 /usr/lib64/libbd_nvdimm.so.2.0.0 /usr/lib64/libbd_part.so.2 /usr/lib64/libbd_part.so.2.0.0 /usr/lib64/libbd_part_err.so.2 /usr/lib64/libbd_part_err.so.2.0.0 /usr/lib64/libbd_swap.so.2 /usr/lib64/libbd_swap.so.2.0.0 /usr/lib64/libbd_utils.so.2 /usr/lib64/libbd_utils.so.2.1.0 /usr/lib64/libbd_vdo.so.2 /usr/lib64/libbd_vdo.so.2.0.0 /usr/lib64/libblockdev.so.2 /usr/lib64/libblockdev.so.2.0.0 /usr/lib64/python2.7/site-packages/gi/overrides/BlockDev.py /usr/lib64/python3.3/site-packages/gi/overrides/BlockDev.py /usr/share/doc/libblockdev-2.22 /usr/share/doc/libblockdev-2.22/LICENSE

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.