[repositories] devel: [groups] [packages] [maintainers] [changelog]

 libva: VAAPI (Video Acceleration API) Library for Linux

Name:libva
Release:2.4.1-1mamba
Architecture:i586
Group:System/Libraries
Description:The main motivation for VAAPI (Video Acceleration API) is to enable hardware accelerated video decode/encode at various entry-points (VLD, IDCT, Motion Compensation etc.) for the prevailing coding standards today (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3). Extending XvMC was considered, but due to its original design for MPEG-2 MotionComp only, it made more sense to design an interface from scratch that can fully expose the video decode capabilities in today's GPUs.
The current video decode/encode interface is window system independent, so that potentially it can be used with graphics sub-systems other than X. In a nutshell it is basically a scheme to pass various types of data buffers from the application to the GPU for decoding or encoding. Feedback on the API is greatly welcomed, as this is intended to be a community collaborative effort.
Size:263.92 KB
Download:libva-2.4.1-1mamba.i586.rpm
Source RPM:libva
Provides:libva-drm.so.2 libva-glx.so.2 libva-wayland.so.2 libva-x11.so.2 libva.so.2 libva.so.2(VA_API_0.32.0) libva.so.2(VA_API_0.33.0) libva[=2.4.1-1mamba]
Requires:/sbin/ldconfig /sbin/ldconfig libGL.so.1(libGL-fglrx-legacy-X11|libGL-fglrx-X11|libGL-Mesa-dri|libGL-Mesa-dri|libGL-nvidia-X11|libGL-nvidia-X11|libGL-nvidia_304-X11|libGL-nvidia_304-X11|libGL-nvidia_340-X11|libGL-nvidia_340-X11|VirtualBox) libX11.so.6 libXau.so.6 libXdmcp.so.6 libXext.so.6 libXfixes.so.3 libbsd.so.0 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.4) libc.so.6(GLIBC_2.7) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libdrm.so.2 libffi.so.6 libm.so.6 libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.2) librt.so.1 libva-x11.so.2 libva.so.2 libwayland-client.so.0 libxcb.so.1
RPM requirements:ldconfig libGL.so.1(libGL-fglrx-legacy-X11|libGL-fglrx-X11|libGL-Mesa-dri|libGL-Mesa-dri|libGL-nvidia-X11|libGL-nvidia-X11|libGL-nvidia_304-X11|libGL-nvidia_304-X11|libGL-nvidia_340-X11|libGL-nvidia_340-X11|VirtualBox) libX11 libXau libXdmcp libXext libXfixes libbsd glibc libdrm libffi glibc libwayland libxcb
Required by:ffmpeg3(i586) libavcodec-ffmpeg(i586) libavcodec-ffmpeg3(i586) libavfilter-ffmpeg(i586) libavfilter-ffmpeg3(i586) libavidemux2(i586) libavutil-ffmpeg(i586) libavutil-ffmpeg3(i586) libqtav(i586) libspice-gtk(i586) libva-devel(i586) libvlc(i586) spice-gtk(i586) wine-core(i586)
Build required by:
Filenames:/usr/lib/libva-drm.so.2 /usr/lib/libva-drm.so.2.401.0 /usr/lib/libva-glx.so.2 /usr/lib/libva-glx.so.2.401.0 /usr/lib/libva-wayland.so.2 /usr/lib/libva-wayland.so.2.401.0 /usr/lib/libva-x11.so.2 /usr/lib/libva-x11.so.2.401.0 /usr/lib/libva.so.2 /usr/lib/libva.so.2.401.0 /usr/share/doc/libva-2.4.1 /usr/share/doc/libva-2.4.1/COPYING

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.