[repositories] devel: [groups] [packages] [maintainers] [changelog]

 speech-dispatcher: A high-level device independent layer for speech synthesis (source)

Name:speech-dispatcher
Release:0.9.1-3mamba
Group:System/Multimedia
Maintainer:silvan
Description:The goal of Speech Dispatcher project is to provide a high-level device independent layer for speech synthesis through a simple, stable and well documented interface.
Key features:
* Common interface to different TTS engines
* Handling concurrent synthesis requests - requests may come assynchronously from multiple sources within an application and/or from more different applications
* Subsequent serialization, resolution of conflicts and priorities of incomming requests
* Context switching - state is maintained for each client connection independently, event for connections from within one application
* High-level client interfaces for popular programming languages
* Common sound output handling - audio playback is handled by Speech Dispatcher rather than the TTS engine, since most engines have limited sound output capabilities

What is a very high level GUI library to graphics, Speech Dispatcher is to speech synthesis.
The application neither needs to talk to the devices directly nor to handle concurrent access, sound output and other tricky aspects of the speech subsystem.
License:LGPL
Size:786.15 KB
Download:speech-dispatcher-0.9.1-3mamba.src.rpm
URL:http://www.freebsoft.org/speechd
Specfile:speech-dispatcher.spec
Sources:speechd-0.9.1.tar.bz2 speech-dispatcher.init
Patches:speech-dispatcher-0.7.1-alsa_set_default.patch speech-dispatcher-0.8-enable_espeak_mbrola.patch speech-dispatcher-0.8-pkgconfig-add-includedir.patch 
Build time:Mon Nov 04 2019
Built RPMS:libspeechd(i586) libspeechd-devel(i586) python-speechd(i586) speech-dispatcher(i586) speech-dispatcher-espeak-ng(i586) speech-dispatcher-festival(i586) speech-dispatcher-flite(i586) libspeechd(arm) libspeechd-devel(arm) python-speechd(arm) speech-dispatcher(arm) speech-dispatcher-espeak-ng(arm) speech-dispatcher-festival(arm) speech-dispatcher-flite(arm) libspeechd(x86_64) libspeechd-devel(x86_64) python-speechd(x86_64) speech-dispatcher(x86_64) speech-dispatcher-espeak-ng(x86_64) speech-dispatcher-festival(x86_64) speech-dispatcher-flite(x86_64)
Build requirements:glibc-devel libalsa-devel libao-devel libdotconf-devel libespeak-ng-devel libflac-devel libglib-devel libltdl-devel libogg-devel libpulseaudio-devel libpython-devel libsndfile-devel libvorbis-devel python-xdg-py36
Changelog:Mon Nov 04 2019 - silvan (0.9.1-3mamba)
- rebuilt with espeak-ng-support
Sat Nov 02 2019 - silvan (0.9.1-2mamba)
- require espeak-ng instead of espeak and espeak-mbrola
Mon May 13 2019 - autodist (0.9.1-1mamba)
- automatic version update by autodist
Tue Mar 19 2019 - silvan (0.9.0-2mamba)
- fix for missing version in headers
Sun Mar 17 2019 - silvan (0.9.0-1mamba)
- update to 0.9.0
Sun Dec 03 2017 - silvan (0.8.8-3mamba)
- libspeechd-devel: provide and obsolete speech-dispatcher-devel
Sun Nov 19 2017 - silvan (0.8.8-2mamba)
- added libspeechd and libspeechd-devel (obsoleting speech-dispatcher-devel)
Sat Nov 18 2017 - autodist (0.8.8-1mamba)
- automatic update by autodist
Wed Aug 09 2017 - autodist (0.8.7-1mamba)
- automatic version update by autodist
Tue Jan 10 2017 - autodist (0.8.6-1mamba)
- automatic version update by autodist
Thu Sep 01 2016 - autodist (0.8.5-1mamba)
- automatic version update by autodist
Thu May 19 2016 - autodist (0.8.4-1mamba)
- automatic version update by autodist
Fri Jun 19 2015 - autodist (0.8.3-1mamba)
- automatic version update by autodist
Tue Mar 31 2015 - autodist (0.8.2-1mamba)
- automatic update by autodist
Thu Oct 16 2014 - autodist (0.8.1-1mamba)
- automatic version update by autodist
Mon Apr 01 2013 - silvan (0.8-2mamba)
- fix pkgconfig file to add includes path as required by chromium >= 26
Sun Mar 10 2013 - autodist (0.8-1mamba)
- automatic version update by autodist
Sat Jul 14 2012 - silvan (0.7.1-2mamba)
- rebuilt with libdotconf 1.3
- obsolete opentts
- integrate python-speech-dispatcher into main package as it is for internal use
- set alsa as default output
- enable espeak-generic and espeak-mbrola-generic modules
- require espeak and espeak-mbrola
Wed Feb 09 2011 - autodist (0.7.1-1mamba)
- automatic update by autodist
Tue Feb 16 2010 - davide (0.6.7-4mamba)
- new subpackages speech-dispatcher-devel and python-speech-dispatcher
- install all the info files
- own /usr/share/speech-dispatcher and /usr/lib64/speech-dispatcher
Wed Sep 23 2009 - silvan (0.6.7-3mamba)
- don't activate service on boot because it blocks alsa to other applications
Wed Sep 23 2009 - silvan (0.6.7-2mamba)
- added initscript
Tue Sep 22 2009 - silvan (0.6.7-1mamba)
- package created by autospec

[repositories] devel: [groups] [packages] [maintainers] [changelog]

Automatically generated by distromatic.